© Agilent Technologies, Inc. 2000-2008
5301 Stevens Creek Blvd., Santa Clara, CA 95052 USA
No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Acknowledgments
Mentor Graphics is a trademark of Mentor Graphics Corporation in the U.S. and other countries. Microsoft®, Windows®, MS Windows®, Windows NT®, and MS-DOS® are U.S. registered trademarks of Microsoft Corporation. Pentium® is a U.S. registered trademark of Intel Corporation. PostScript® and Acrobat® are trademarks of Adobe Systems Incorporated. UNIX® is a registered trademark of the Open Group. Java™ is a U.S. trademark of Sun Microsystems, Inc. SystemC® is a registered trademark of Open SystemC Initiative, Inc. in the United States and other countries and is used with permission. MATLAB® is a U.S. registered trademark of The Math Works, Inc. HiSIM2 source code, and all copyrights, trade secrets or other intellectual property rights in and to the source code in its entirety, is owned by Hiroshima University and STARC.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file names and directory names. The business entity formerly known as "HP EEsof" is now part of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and to maintain backward compatibility for our customers, we did not change all the names and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license. Portions of this product include the SystemC software licensed under Open Source terms, which are available for download at http://systemc.org/. This software is redistributed by Agilent. The Contributors of the SystemC software provide this software "as is" and offer no warranty of any kind, express or implied, including without limitation warranties or conditions or title and non-infringement, and implied warranties or conditions merchantability and fitness for a particular purpose. Contributors shall not be liable for any damages of any kind including without limitation direct, indirect, special, incidental and consequential damages, such as lost profits. Any provisions that differ from this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily provided to end user customers. Agilent provides this customary commercial license in Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212 (Computer Software) and, for the Department of Defense, DFARS 252.227-7015 (Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial Computer Software or Computer Software Documentation).
**Advanced Design System 2008 - LineCalc**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using LineCalc</td>
<td>6</td>
</tr>
<tr>
<td>The Basic LineCalc Process</td>
<td>6</td>
</tr>
<tr>
<td>Key Terms</td>
<td>6</td>
</tr>
<tr>
<td>Starting LineCalc</td>
<td>7</td>
</tr>
<tr>
<td>The LineCalc Window</td>
<td>7</td>
</tr>
<tr>
<td>Title Bar, Toolbar, and Menu Bar</td>
<td>8</td>
</tr>
<tr>
<td>Component Display</td>
<td>8</td>
</tr>
<tr>
<td>Shared Parameters Display</td>
<td>8</td>
</tr>
<tr>
<td>Parameters Display</td>
<td>9</td>
</tr>
<tr>
<td>Results Display</td>
<td>10</td>
</tr>
<tr>
<td>Status Bar</td>
<td>10</td>
</tr>
<tr>
<td>LineCalc Menus and Commands</td>
<td>11</td>
</tr>
<tr>
<td>Changing the Default Data Directory</td>
<td>11</td>
</tr>
<tr>
<td>Opening a Component File</td>
<td>11</td>
</tr>
<tr>
<td>Opening a Previously-Saved LineCalc Component File</td>
<td>12</td>
</tr>
<tr>
<td>Importing Components from the Active Design</td>
<td>13</td>
</tr>
<tr>
<td>Selecting a Component</td>
<td>14</td>
</tr>
<tr>
<td>Displaying Component Help</td>
<td>14</td>
</tr>
<tr>
<td>Changing Default Units</td>
<td>15</td>
</tr>
<tr>
<td>Changing Parameter Values</td>
<td>15</td>
</tr>
<tr>
<td>Interdependent Values for Electrical Parameters</td>
<td>16</td>
</tr>
<tr>
<td>Fixed Values for Physical Parameters</td>
<td>16</td>
</tr>
<tr>
<td>Performing a Synthesis</td>
<td>17</td>
</tr>
<tr>
<td>Performing an Analysis</td>
<td>18</td>
</tr>
<tr>
<td>Updating Schematics with LineCalc Results</td>
<td>18</td>
</tr>
<tr>
<td>Saving Results</td>
<td>18</td>
</tr>
<tr>
<td>Printing</td>
<td>19</td>
</tr>
<tr>
<td>Exiting the Program</td>
<td>20</td>
</tr>
<tr>
<td>Using AEL Commands</td>
<td>20</td>
</tr>
<tr>
<td>Using Macros to Automate Tasks</td>
<td>21</td>
</tr>
<tr>
<td>LineCalc Components</td>
<td>24</td>
</tr>
<tr>
<td>Components and Parameters</td>
<td>24</td>
</tr>
<tr>
<td>References/Shared Parameters</td>
<td>25</td>
</tr>
<tr>
<td>Parameter Definitions</td>
<td>26</td>
</tr>
<tr>
<td>Changing Parameter Defaults</td>
<td>27</td>
</tr>
<tr>
<td>LineCalc Error Messages</td>
<td>29</td>
</tr>
<tr>
<td>LineCalc AEL Functions</td>
<td>38</td>
</tr>
<tr>
<td>lcuuser_analyze()</td>
<td>38</td>
</tr>
<tr>
<td>lcuuser_elemid_select()</td>
<td>38</td>
</tr>
<tr>
<td>lcuuser_elemid_select_apply()</td>
<td>39</td>
</tr>
<tr>
<td>lcuuser_elemtype_select()</td>
<td>39</td>
</tr>
<tr>
<td>lcuuser_elemtype_select_apply()</td>
<td>39</td>
</tr>
<tr>
<td>lcuuser_file_chdir_ok()</td>
<td>39</td>
</tr>
<tr>
<td>lcuuser_file_exit()</td>
<td>40</td>
</tr>
</tbody>
</table>
lcuiuser_file_new() ................................................................. 40
lcuiuser_file_open_ok() ......................................................... 41
lcuiuser_file_print() ........................................................... 41
lcuiuser_file_print_setup() ..................................................... 42
lcuiuser_file_save() ............................................................. 42
lcuiuser_file_save_as_ok() ...................................................... 43
lcuiuser_option_cmdline_apply() ........................................... 43
lcuiuser_option_pbmacro_ok() ................................................ 44
lcuiuser_set_angle_unit() ....................................................... 44
lcuiuser_set_elec_res_unit() .................................................. 45
lcuiuser_set_electricalParms() .............................................. 45
lcuiuser_set_freq_unit() ......................................................... 46
lcuiuser_set_freq_value() ....................................................... 46
Syntax: ............................................................................... 46
Example ............................................................................... 46
lcuiuser_set_length_unit() ....................................................... 47
lcuiuser_set_mwall_length_unit() ............................................ 47
lcuiuser_set_physicalParms() ................................................. 48
lcuiuser_set_physicalParms_all() .......................................... 48
lcuiuser_set_physicalParms_fix() ............................................ 48
lcuiuser_set_phys_length_unit() ............................................. 49
lcuiuser_set_res_unit() ......................................................... 49
lcuiuser_set_sharedParms() ..................................................... 50
lcuiuser_set_subst_length_unit() ............................................ 50
lcuiuser_set_subst_parm_value() ............................................ 50
lcuiuser_simulation_analyze() .............................................. 51
lcuiuser_simulation_interrupt() ............................................. 51
lcuiuser_simulation_stop() .................................................... 52
lcuiuser_simulation_synthesize() .......................................... 52
lcuiuser_synthesize() ............................................................ 53
Using LineCalc

LineCalc is an analysis and synthesis program for calculating electrical and physical parameters of single and coupled transmission lines.

LineCalc can communicate directly with the circuit simulators. You can send parameter data for selected circuit design elements, along with data on any associated substrates or walls, directly from the simulator to LineCalc. After the element parameter values are calculated, you can update the associated schematic or layout circuit design in the active simulator immediately with the LineCalc results. Or you can place a newly synthesized component into the Schematic window.

Using dialog boxes, you can make changes in parameter values of your transmission lines and see the results of those changes on the screen. You can use LineCalc like a spreadsheet, in the sense that a change in one value brings about a recalculation through all related values when you choose the appropriate Calculate button.

You can print results, save results to an element data file, or instantly update a schematic or layout in a circuit design.

Note

LineCalc cannot be used with the signal processing simulators.

The Basic LineCalc Process

- Select a LineCalc component.
- Select one or more independent parameters for calculation.
- Change default parameter values, as necessary.
- Perform the analysis or synthesis.
- Update the design, if applicable.

Key Terms

Analysis Calculation of electrical parameters from physical data.

Synthesis Calculation of physical parameters from electrical data.

Shared Parameters Parameters common to a group of components and required for both analysis and synthesis.

LineCalc File (<filename>.lcs) The data file created when results from a LineCalc analysis or synthesis of a component are saved. The file contains information about the component's parameters, associated shared parameters, frequency, and units to support design iteration. This data file is created when you save results from a LineCalc analysis or
synthesis of a component. The file contains information about the component's parameters, associated shared parameters, frequency, and units to support design iteration.

**Starting LineCalc**

Before running LineCalc, you should be familiar with the basic operation of the ADS design environment. (For details, refer to the *Schematic Capture and Layout* manual.)

To run LineCalc from within the Design Environment:

- From the Schematic window, choose **Tools > LineCalc > Start LineCalc**.
- To run LineCalc in stand-alone mode:
  - On the PC, from the Start menu choose **Programs > Advanced Design System 2006A > ADS Tools > LineCalc**.
  - On UNIX, in a terminal window, type **linecalc**.

**Note**

Starting LineCalc in this manner assumes you have established a path to the ADS installation directory. If you have not, type `<install_dir>/bin/linecalc`, where `<install_dir>` represents your complete installation path. For details on establishing a path statement, refer to Chapter 2 of the *UNIX and Linux Installation* manual.

When LineCalc is launched, the LineCalc window appears, as well as the Message/Status window. The Message/Status window displays messages about the status of the current process as well as warning messages.

**The LineCalc Window**

The LineCalc window is divided into several regions.

- **Title Bar, Toolbar, and Menu Bar**
- **Component Display**
- **Shared Parameters Display**
- **Parameters Display**
- **Results Display**
- **Status Bar**
The following sections describe these regions.

**Title Bar, Toolbar, and Menu Bar**

The *Title bar* displays the application name and the name of the active data file (or untitled if no data file is associated with the data being displayed).

The *Toolbar* contains buttons for frequently-used commands. The *Menu bar* displays the available menus and commands.

**Component Display**

The *Component* display lists the currently-selected component type and ID. You can choose a different component type and ID to analyze or synthesize, by the *Selection arrow*.

**Shared Parameters Display**

The *Shared Parameters* display consists of the Substrate Parameters and the Component Parameters sections. The parameters shared by all components with substrate parameters are listed in the Substrate Parameters area. The parameters shared by components with frequency or mwall parameters are listed in the Component Parameters area.
Parameters Display

The Parameters display lists the physical and electrical parameter values of the currently-selected component. In the Physical section, the Fix button indicates the status of the associated physical parameter:

- If the button indicates Fixed, the adjacent parameter is fixed during synthesis.
- If the button indicates Fix, the adjacent parameter is updated during synthesis.

You can compute the physical parameter values from electrical data by clicking Synthesize and clicking Analyze computes the electrical component parameters from physical data.
**Results Display**

The *Results* display shows the parameter values that change as a result of the synthesis or analysis. These are displayed as the calculated results.

---

**Status Bar**

The *Status Bar* at the bottom of the window shows the status of your displayed data. When you have changed a parameter value without recalculation (synthesis or analysis), the message appears: *Parameter(s) modified - Values are not consistent.* After you perform the calculation, the message appears: *Values are consistent.*
LineCalc Menus and Commands

This section describes the LineCalc Menus and Commands. The LineCalc User Interface has the following menus:

- File Menu
- Simulation Menu
- Options Menu
- Help Menu

Changing the Default Data Directory

The LincCalc program reads the files from and save these to your program startup directory, unless you change the default directory.

To use an alternate directory during your current program session:

1. From the Synthesis/LineCalc window, choose File > Change Dir.
2. Use the displayed dialog box to specify a directory path (other than the program startup directory) for reading and saving files until you exit the program.

Resetting the Display

You must clear any currently active work before selecting or importing components for a new synthesis or analysis.

- To save your work, choose File > Save; then choose File > New.
- To cancel a design in progress and start over, choose File > New.

Note
Choosing New displays the default component.

Opening a Component File

After resetting the display, you can activate a component that you want to synthesize or analyze in one of these ways:

- By opening a previously-saved LineCalc component file, or
- By importing components from the active schematic or layout design
Note
When you activate LineCalc, the last-saved component is displayed. Clear the display before opening a component file (see Resetting the Display).

Opening a Previously-Saved LineCalc Component File

You can activate a component that you want to synthesize or analyze by opening a previously-saved LineCalc component file.

To open a previously-saved LineCalc component file:

1. Choose File > Open to display the dialog box.

2. Specify the path to the directory where the component file is located. Click Filter to activate a list of data files in the specified directory. This step may not be necessary if the file is located in your current directory or if you changed your default data directory.

Note
Choosing a file from a different directory does not change the default directory.

3. In the Data Files list, select the component file. The component data saved to that file becomes active in the LineCalc window.
Importing Components from the Active Design

You can activate a component that you want to synthesize or analyze by importing components from the active schematic or layout design.

To import components from an active design:

1. In the Schematic or Layout window, select the component you want to send to LineCalc. In the illustration, a portion of a schematic example, MLIN:TL2 is selected.

   Note
   You can send only one component at a time.

2. Choose Tools > Send Selected Components to LineCalc. The component data for all selected components is sent to LineCalc.

In the LineCalc window, each component that you import from the Schematic or Layout window, along with its ID name, is listed in the Component ID Selection dialog box. In the illustration the two MLINs (TL2 and TL3) that were sent to LineCalc from the Schematic window are now displayed in the Component ID Selection list and can be selected for evaluation.

Only one component/ID calculation can be performed at a time. For example, select and perform any calculations on MLIN:TL3 before you attempt to select and modify MLIN:TL2.
Selecting a Component

**Note**
Before selecting or importing components to begin a new synthesis or analysis, be sure to clear any currently active work. See Resetting the Display.

To select a component:

1. In the Component ID field, click **Select** to display the dialog box. The LineCalc window changes to display the active Component Type, Component ID, parameters, and other data.

2. Select the component you want displayed and click OK to accept the component and dismiss the dialog. Click Apply to accept the component and keep the dialog open.

Displaying Component Help

To display detailed information for a component, select Help > What's This? and place the question mark on the component illustration.
Changing Default Units

You can modify program units or frequencies before calculating the results by setting the Frequency, Length, Resistance, and Angle units.

To modify default units or frequencies:

1. In the Menu bar, select Options > Preferences. Change the default unit preferences by selecting from the drop-down lists. Default Units lists program options.

<table>
<thead>
<tr>
<th>Unit</th>
<th>Options</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency</td>
<td>GHz, MHz, kHz, Hz</td>
<td>GHz</td>
</tr>
<tr>
<td>Length</td>
<td>in, mil, m, cm, mm, um</td>
<td>mil</td>
</tr>
<tr>
<td>Resistance</td>
<td>kohm, ohm</td>
<td>ohm</td>
</tr>
<tr>
<td>Angle</td>
<td>deg, rad</td>
<td>deg</td>
</tr>
</tbody>
</table>

2. In the Units display, modify the settings and click OK to accept your changes. The newly-chosen unit is reflected when a new component is chosen.

Changing Parameter Values

To change any values in the Physical or Electrical parameter fields:

- Select the value and type a new value in the field.

To change Shared parameter values:

- Select the default value and type a new value in the field.
- To change the units associated with each shared parameter, select the units button next to each parameter field.
Interdependent Values for Electrical Parameters

For certain components, some of the electrical parameter values depend on the current values assigned to other parameters. In the following illustration, note the beginning values for ZO and Z0 in the Electrical portion of the Parameters display for the MCLIN component.

To observe the values of related parameters change automatically, change the value of ZO to 22 and press Enter (or click one of the other fields containing interdependent parameters).

Original values

<table>
<thead>
<tr>
<th>Electrical</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ZE</td>
<td>65.98Ω</td>
<td>Ohm</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Z0</td>
<td>36.11Ω</td>
<td>Ohm</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Z0</td>
<td>48.81536Ω</td>
<td>Ohm</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C_DB</td>
<td>-10.676428</td>
<td>N/A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>E_Eff</td>
<td>77.831206Ω</td>
<td>deg</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Modified values

<table>
<thead>
<tr>
<th>Electrical</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ZE</td>
<td>65.98Ω</td>
<td>Ohm</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Z0</td>
<td>22.00Ω</td>
<td>Ohm</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Z0</td>
<td>38.09992Ω</td>
<td>Ohm</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C_DB</td>
<td>-6.022377</td>
<td>N/A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>E_Eff</td>
<td>77.831206Ω</td>
<td>deg</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The display updates to show that the corresponding Z0 value changed from 48.815 to 38.099. Also, the C_DB value changed from −10.676 to −6.022. Generally, the last two visited fields are used to compute the other parameters.

Fixed Values for Physical Parameters

Certain components require the value of one of the physical parameters to be fixed (not modifiable) during synthesis. For these components, one parameter must be assigned a fixed value before you can perform a synthesis. For example, observe how the W and G parameters of the CPW component are interrelated. By default, when you select the CPW component, the value of G is fixed and the value of W is not. This default condition is shown by the label on the Fixed button, which is dimmed.
If you want to change the value of G, you must click the Fix button for W. The new condition is shown by the label on the button which changes to read Fixed and is dimmed. An active Fix button on the G value indicates that value is currently not fixed and will change during synthesis.

Performing a Synthesis

A synthesis computes the physical parameter values based on the electrical parameter values.

To synthesize a revised component:

- Select **Simulate > Compute Physical Params** or click **Calculate** (Up button) in the Parameters display. The values for physical parameters (shown in the upper
portion of the display) are computed from the electrical values and the values in the Results display are updated.

**Performing an Analysis**

An analysis computes the electrical component parameters based on the physical parameter values.

To analyze a revised component:

- Select **Simulate > Compute Electrical Params** or click **Calculate** (Down button) in the Parameters display. The values for electrical parameters (shown in the lower portion of the display) are computed from the physical values and the values in the Results display are updated.

**Updating Schematics with LineCalc Results**

After performing a synthesis or analysis, you can place the component to the Schematic window.

In the Schematic window, select **Tools > Linecalc > Place New Synchronized Component**.

If you start LineCalc from the Schematic and send selected components to LineCalc for synthesis or analysis, you can update your schematic when your calculations are complete.

In the Schematic window, select the component to be updated. Then select **Tools > LineCalc > Update Selected Component From LineCalc**.

**Saving Results**

To save a LineCalc component file:

- Choose **File > Save** from the Synthesis/LineCalc window. The program automatically saves the filename with an .lcs extension. Unless you change the default data directory, the data file is saved in the program startup directory.
To save a LineCalc component file to a different data file:

1. In the Synthesis/LineCalc window, choose **File > Save As**.
2. In the dialog box, enter a filename and specify a directory path.
   To save a design that was modified by LineCalc calculations:
   
   - In the Schematic or Layout window, choose **File > Save**.

**Printing**

You can print the data for a component.

- To specify a printing configuration, choose **File > Print Setup**.
- To print the data associated with the currently displayed component, choose **File > Print**.

The printed data format is:

- product information
- date information
- component type
component ID
units information
frequency value
shared parameters
physical parameters
electrical parameters
result parameters

Note
For detailed information on print and print setup options, refer to your operating system documentation.

Exiting the Program

To exit LineCalc:

1. Choose File > Exit. If any unsaved changes are detected, you are prompted, Do you want to save the design?
2. Select Yes or No, as appropriate.
   If you select Yes, and the currently active file had not been saved previously (that is, labeled untitled at the top of the window), the Save As dialog box appears, prompting you for a filename.

Using AEL Commands

Using the program's Applications Extension Language (AEL), you can create entries for user-defined components, customize the contents of library and palette menus, and write customized commands. For configuration details on using AEL, see the AEL manual.

To execute AEL commands:

- Choose Options > Command Line to open the Command Line dialog.
• Type the command(s) in the Command >> field or select one of the commands in the Command History list. Click Apply to execute the command. You can double-click a command in the list to select and execute it.

Note
All commands entered in the Command >> field must be in correct AEL format.

Using Macros to Automate Tasks

Creating a Macro File
To create a macro file:

• Using any text editor, create a file in one of your project directories and type the lines containing the AEL functions you want to execute. The filename must have the extension .ael.

Recording a Macro
To record a macro:

• Choose Options > Command Line to open the Command Line dialog.
1. Select **Options > Start Record Macro**. In the dialog, enter a filename for the macro file you are going to record and choose OK to close the dialog.

   ![Start Macro Recording dialog](image)

   - The macro file extension is `.lcm`
   - Enter a filename for the macro

2. In the Command Line dialog, the Command History displays all actions taken in the LineCalc window during the recording. Alternatively, enter the AEL functions you want to record in the Command >> field.

3. Select **Options > Stop Record Macro** to stop recording.

### Running a Macro from the Design Environment

To play back a macro:

1. Choose **Options > Playback Macro**. A dialog displays all the `.lcm` files in the current project directory. You can browse to display macros from another directory.
2. Select the macro you want to play back and click OK to execute the selected macro.

**Running a Macro from the UNIX Command Line**

To run a macro file from the UNIX command line:

- Change directories (cd) to your working directory and type:

  ```
  $ linecalc -m <filename>.lcm
  
  or
  
  $ linecalc -m synthesize.lcm
  ```
## LineCalc Components

### Components and Parameters

Components and Associated Parameters lists the LineCalc-supported components and any associated parameters that can be modified or calculated. Components are grouped by substrates and details regarding their electrical and physical values, references, and other computed results are given.

<table>
<thead>
<tr>
<th>Component</th>
<th>Electrical Parameters</th>
<th>Physical Parameters</th>
<th>Substrate Parameters</th>
<th>Calculated Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>COAX</td>
<td>Z0 E_Eff</td>
<td>Di Do L</td>
<td>Er TanD Rho Sigma</td>
<td>A_DB</td>
</tr>
<tr>
<td>RWG</td>
<td>Z0 E_Eff</td>
<td>A B L</td>
<td>Er Rho TanD Mur TanM Sigma</td>
<td>K_Eff A_DB</td>
</tr>
</tbody>
</table>

Components using the CPWSUB substrate (CPWSUB = * )

<table>
<thead>
<tr>
<th>Component</th>
<th>Electrical Parameters</th>
<th>Physical Parameters</th>
<th>Substrate Parameters</th>
<th>Calculated Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPW</td>
<td>Z0 E_Eff</td>
<td>W G L</td>
<td>Er Mur H Hu T Cond TanD Rough</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
<tr>
<td>CPWCPL2</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W G S L</td>
<td>Er Mur H Hu T Cond TanD Rough</td>
<td>KE KO AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>CPWCPL4</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W = Wi G S = Si L</td>
<td>Er Mur H Hu T Cond TanD Rough</td>
<td>K_Eff KE KO AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>CPWG</td>
<td>Z0 E_Eff</td>
<td>W G L</td>
<td>Er Mur H Hu T Cond TanD Rough</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
</tbody>
</table>

Components using the FSUB substrate (FSUB = * )

<table>
<thead>
<tr>
<th>Component</th>
<th>Electrical Parameters</th>
<th>Physical Parameters</th>
<th>Substrate Parameters</th>
<th>Calculated Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>BFINL</td>
<td>Z0 E_Eff</td>
<td>D L</td>
<td>Er Cond Fa Fb Fdw</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
<tr>
<td>IFINL</td>
<td>Z0 E_Eff</td>
<td>D L</td>
<td>Er Cond Fa Fb Fdw</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
<tr>
<td>UFINL</td>
<td>Z0 E_Eff</td>
<td>D L</td>
<td>Er Cond Fa Fb Fdw</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
</tbody>
</table>

Components using the MSUB substrate (MSUB = * )

<table>
<thead>
<tr>
<th>Component</th>
<th>Electrical Parameters</th>
<th>Physical Parameters</th>
<th>Substrate Parameters</th>
<th>Calculated Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>MCLIN</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W S L</td>
<td>Er Mur H Hu T Cond TanD Rough</td>
<td>KE KO AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>MLANG</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W S L</td>
<td>ER Mur H Hu T Cond TanD Rough</td>
<td>KE KO AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>---------</td>
<td>---------------------</td>
<td>------</td>
<td>-------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>MLANG6</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W S L</td>
<td>ER Mur H Hu T Cond TanD Rough</td>
<td>KE KO AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>MLANG8</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W S L</td>
<td>ER Mur H Hu T Cond TanD Rough</td>
<td>KE KO AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>MLIN</td>
<td>Z0 E_Eff</td>
<td>W L</td>
<td>ER Mur H Hu T Cond TanD Rough</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
</tbody>
</table>

Components using the SSUB substrate (SSUB = * )

<table>
<thead>
<tr>
<th>SBCLIN</th>
<th>ZE ZO Z0 C_DB E_Eff</th>
<th>W S L</th>
<th>ER Mur B T Cond TanD</th>
<th>AE_DB AO_DB SkinDepth</th>
</tr>
</thead>
<tbody>
<tr>
<td>SCLIN</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W S L</td>
<td>ER Mur B T Cond TanD</td>
<td>AE_DB AO_DB SkinDepth</td>
</tr>
<tr>
<td>SLIN</td>
<td>Z0 E_Eff</td>
<td>W L</td>
<td>ER Mur B T Cond TanD</td>
<td>A_DB SkinDepth</td>
</tr>
<tr>
<td>SLINO</td>
<td>Z0 E_Eff</td>
<td>W S L</td>
<td>ER Mur B S T Cond TanD</td>
<td>A_DB SkinDepth</td>
</tr>
<tr>
<td>SOCLIN</td>
<td>ZE ZO Z0 C_DB E_Eff</td>
<td>W WO S L</td>
<td>ER Mur B T Cond TanD</td>
<td>AE_DB AO_DB SkinDepth</td>
</tr>
</tbody>
</table>

Components using the SSSUB substrate (SSSUB = * )

<table>
<thead>
<tr>
<th>SSCLIN</th>
<th>ZE ZO Z0 C_DB E_Eff</th>
<th>W S L</th>
<th>ER Mur H Hu HI T Cond TanD Rough</th>
<th>KE KO AE_DB AO_DB SkinDepth</th>
</tr>
</thead>
<tbody>
<tr>
<td>SSLIN</td>
<td>Z0 E_Eff</td>
<td>W L</td>
<td>ER Mur H Hu HI T Cond TanD Rough</td>
<td>K_Eff A_DB SkinDepth</td>
</tr>
</tbody>
</table>

**References/Shared Parameters**

References/Shared Parameters lists the LineCalc-supported references/shared parameters.
### References/Shared Parameters

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Parameter Name</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPWSUB</td>
<td>Er H T Cond Rough TanD Hu Mur COND</td>
<td>10.0 25.0 0.150 4.1e7 0.0 0.0 3.9e+07 mil 1.0 Cond</td>
</tr>
<tr>
<td>FSUB</td>
<td>Er Fdw Fa Fb Cond</td>
<td>2.2 62.5 mil 900.0 mil 400.0 mil 5.8e7</td>
</tr>
<tr>
<td>MSUB</td>
<td>Er H T Cond Cond1 Cond2 Rough TanD Hu Mur Diel1 Diel2 Hole Res</td>
<td>9.6 10 mil 0.150 4.1e7 Cond Cond1 0.0 0.0 3.9e+34m 1.0 Diel Diel1 hole resi</td>
</tr>
<tr>
<td>SSSUB</td>
<td>Er H T Cond Rough HU HL TanD Mur COND</td>
<td>10.0 25.0 0.150 4.1e7 0.0 100.0 100.0 0.0 1.0 Cond</td>
</tr>
<tr>
<td>SSUB</td>
<td>Er B T Cond Cond1 Cond2 TanD Mur</td>
<td>2.5 62.5 0.150 5.8e7 Cond Con1 0.0 1.0</td>
</tr>
</tbody>
</table>

Note: The default MSUB Cond value has changed to be 4.1e7 (the conductivity of gold).

### Parameter Definitions

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Width of rectangular waveguide</td>
</tr>
<tr>
<td>A_DB</td>
<td>Total attenuation of the structure in dB</td>
</tr>
<tr>
<td>AE_DB</td>
<td>Total even mode attenuation of coupled section in dB</td>
</tr>
<tr>
<td>AO_DB</td>
<td>Total odd mode attenuation of coupled section in dB</td>
</tr>
<tr>
<td>B</td>
<td>Ground plane spacing from top to bottom (stripline) or height of rectangular waveguide</td>
</tr>
<tr>
<td>C_DB</td>
<td>Coupling factor in dB, i.e., $C(dB) = 20\log_{10} \left( \frac{Z_E-Z_O}{Z_E+Z_O} \right)$</td>
</tr>
<tr>
<td>D</td>
<td>Gap width in length units</td>
</tr>
<tr>
<td>DI</td>
<td>Inner diameter (COAX)</td>
</tr>
<tr>
<td>DO</td>
<td>Outer diameter (COAX)</td>
</tr>
<tr>
<td>E</td>
<td>Electrical length of line or coupled section (angle units)</td>
</tr>
<tr>
<td>E_EFF</td>
<td>Effective electrical length of line or coupled section (angle units)</td>
</tr>
<tr>
<td>E_MEAN</td>
<td>Mean electrical length of coupled microstrip or coplanar waveguide section (angle units)</td>
</tr>
<tr>
<td>ER</td>
<td>Substrate relative dielectric constant</td>
</tr>
<tr>
<td>G</td>
<td>Gap between conductor and ground planes (CPW, CPWG)</td>
</tr>
<tr>
<td>H</td>
<td>Substrate thickness in length units</td>
</tr>
<tr>
<td>HL</td>
<td>Lower ground plane to substrate spacing in length units</td>
</tr>
<tr>
<td>HU</td>
<td>Upper ground plane to substrate spacing in length units</td>
</tr>
<tr>
<td>HC</td>
<td>Distance from top cover to top of substrate in length units</td>
</tr>
<tr>
<td>KE</td>
<td>Even-mode effective dielectric constant: KE=([C/Vp(\text{even mode})]^2)</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>K_EFF</td>
<td>Effective dielectric constant: K_EFF=((C/Vp)^2)</td>
</tr>
<tr>
<td>KO</td>
<td>Odd-mode effective dielectric constant: KO=([C/Vp(\text{odd mode})]^2)</td>
</tr>
<tr>
<td>L</td>
<td>Length of line or coupled section</td>
</tr>
<tr>
<td>MUR</td>
<td>Relative permeability</td>
</tr>
<tr>
<td>Rough</td>
<td>RMS surface roughness in length units</td>
</tr>
<tr>
<td>S</td>
<td>Spacing between lines</td>
</tr>
<tr>
<td>SI</td>
<td>Spacing between inner center conductors (CPWCPL4)</td>
</tr>
<tr>
<td>SIGM</td>
<td>Dielectric conductivity value in Siemens per meter</td>
</tr>
<tr>
<td>T</td>
<td>Metal thickness</td>
</tr>
<tr>
<td>TAND</td>
<td>Dielectric loss tangent</td>
</tr>
<tr>
<td>TANM</td>
<td>Magnetic loss tangent</td>
</tr>
<tr>
<td>TEMP</td>
<td>Temperature; can not be modified by the user</td>
</tr>
<tr>
<td>W</td>
<td>Width of line</td>
</tr>
<tr>
<td>WI</td>
<td>Width of inner center conductors (CPWCPL4)</td>
</tr>
<tr>
<td>WO</td>
<td>Offset of coupled lines for offset coupled stripline</td>
</tr>
<tr>
<td>Ze</td>
<td>Impedance for even-mode</td>
</tr>
<tr>
<td>Zo</td>
<td>Impedance for odd-mode</td>
</tr>
<tr>
<td>Z0</td>
<td>For coupled-line components, such as SCLIN or MCLIN, (Z0=\sqrt{Ze \times Zo})</td>
</tr>
</tbody>
</table>

**Changing Parameter Defaults**

The default parameters that appear in the LineCalc window for editing are set in a file called *lcuiinit* in the directory `$HPEESOF_DIR/linecalc/lib` (where `$HPEESOF_DIR` represents the complete path for your installation). You can make a local copy of this file and change the default parameters so that less editing is required whenever you use LineCalc.

To modify the *lcuiinit* file:

1. Copy the file *lcuiinit* to a directory of your choosing. Using any text editor, make the desired changes. Save the file.
2. Now you need to tell the program where to look for your customized file. Make a local copy of the LineCalc configuration file *linecalc.cfg* found in `$HPEESOF_DIR/config`. Copy this file to `$HOME/hpeesof/config`.
3. Using any text editor, locate the variable *LCALCUI_INIT_FILE* and modify the path to point to the location of your modified *lcuiinit* file.
The component definition format is:

```
ELEMENT <element_name> <element_id> <# of ports> <units> <physical>
[<physical_fixed> <physical>] <subst> <tand> <sigma> <temp> <electrical>
[<electrical_fixed> <electrical>] <result>
```

For example:

```
ELEMENT COAX COAX_DEFAULT 4 UNITS PHYSICAL PHYSICAL_FIXED
PHYSICAL SUBST ELECTRICAL RESULT UNITS UNITS_DEFAULT
FREQ_VAL=10.00 FREQ=GHz LENGTH=mil RES=ohm ANGLE=deg
PHYSICAL DI=37.00
PHYSICAL_FIXED DO=90.00
PHYSICAL L=650.00
SUBST COAXSUB=COAXSUB_DEFAULT ER=2.10 TAND=0.0003 RHO=1.0
ELECTRICAL Z0=35.00 E=90.00
RESULT A_DB=0.01
```
LineCalc Error Messages

This section describes the possible error messages and how to handle each one of them.

**Syntax error in AEL file**

Comment: An error has occurred in an AEL file.

Category: Syntax error in AEL file

How to resolve it: Check the AEL file, confirming that all the parentheses are matched, there are no missing ";", etc.

**AEL files not loaded**

Comment: The AEL files are not loaded due to error(s) occurred.

Category: Syntax error in AEL file

How to resolve it: Check the AEL file, confirming that all the parentheses are matched, there are no missing ";", etc.

**Invoke process failed**

Comment: Unable to invoke process (could be the LineCalc Engine, Help Server, etc.)

Category: Error in the initialization phase

How to resolve it: Confirm that all the necessary tools (LineCalc Engine, Status Server, Help Server, and Hardcopy Server) are available and functional.

**Unable to connect to the Status Server**

Comment: The LineCalc User Interface cannot connect to the Status Server process.

Category: Error in the initialization phase

How to resolve it: Confirm that all the necessary tools (LineCalc Engine, Status Server, Help Server, and Hardcopy Server) are available and functional.

**AEL command not found**

Comment: The specified AEL command is not found

Category: Invalid AEL command.
How to resolve it: Confirm that the command is spelled properly and is indeed a supported function.

**Incomplete config file**

Comment: Some information in the configuration file, linecalc.cfg, is missing.

Category: Error in configuration file.

How to resolve it: Search the *linecalc.cfg* file to find the required information that is missing and replace it. Without this information, the program cannot function.

**Init file not found**

Comment: The initialization file, lcuiinit, is not found.

Category: Error in the initialization file.

How to resolve it: The initialization file must be placed where the program can read it. This is usually `$HPEESOF_DIR/lib/linecalc`. Confirm that all the information is there: the users can add more information to it, but the user should never delete any information from the original initialization file.

**Syntax error in init file**

Comment: A syntax error in the init file, lcuiinit, has been found.

Category: Error in the initialization file.

How to resolve it: The initialization file must be placed where the program can read it. This is usually `$HPEESOF_DIR/lib/linecalc`. Confirm that all the information is there: the users can add more information to it, but the user should never delete any information from the original initialization file.

**Missing units information**

Comment: Units information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing substrate information**

Comment: Substrate information is not found.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing tand information**

Comment: Tand information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing mcover information**

Comment: Mcover information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing mwall information**

Comment: Mwall information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing perm information**

Comment: Perm information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in
the data file.

**Missing sigma information**

Comment: Sigma information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing temp information**

Comment: Temp information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing parameters information**

Comment: Some parameters are missing.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Missing number of nodes information**

Comment: The number of nodes information is missing.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

**Save element type failed**

Comment: Unable to save the component type.

Category: Invalid component type to be saved.

How to resolve it: Confirm that the component type is one of the supported LineCalc components.

**Save element ID failed**
Comment: Unable to save the component ID.

Category: Invalid component ID to be saved.

How to resolve it: This is very unlikely to happen. However if it does happen, it is most likely due to unable to allocate more memory to store the information.

**Save number of nodes information failed**

Comment: Unable to save the number of nodes information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save units information failed**

Comment: Unable to save the units information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save freq unit failed**

Comment: Unable to save the frequency unit information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save length unit failed**

Comment: Unable to save the length unit information.

Category: Unable to save the specified component.
How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save res unit failed**

Comment: Unable to save the resistor unit information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save angle unit failed**

Comment: Unable to save the angle unit information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save substrate information failed**

Comment: Unable to save the substrate information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save mwall information failed**

Comment: Unable to save the mwall information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate
more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save shared parameters failed**

Comment: Unable to save the shared parameters information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save physical parameters information**

Comment: Unable to save the physical parameters information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save electrical parameters information**

Comment: Unable to save the electrical parameters information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Save result parameters failed**

Comment: Unable to save the result parameters information.

Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the information. Another issue which needs to be looked at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.
at is that the information should be in the proper format: if the format is expected to be a number, it should be a number; if the format is expected to be a string, it should be a string type.

**Invalid element type**

Comment: Invalid component type.

Category: Invalid component type.

How to resolve it: An invalid component type has been requested. Confirm that the component type is spelled correctly is indeed a LineCalc supported component.

**Unable to write the data file**

Comment: Unable to save to the specified data file.

Category: Unable to write the data file.

How to resolve it: If this error occurs, the current user probably cannot write to the specified data file; this can also occur if the directory is not writable by the current user.

**Create new shared parameters failed**

Comment: Unable to create a new shared parameters information.

Category: Unable to create a new shared parameters.

How to resolve it: When this error occurs, the program is probably unable to allocate more memory to store the data.

**Invalid substrate**

Comment: Invalid substrate.

Category: Invalid substrate type.

How to resolve it: Confirm the substrate type entered is supported by LineCalc.

**Error Retrieving DONE NETLIST**

Comment: Invalid parameters for analysis/synthesis.

Category: Invalid parameters for analysis/synthesis.

How to resolve it: Ensure the electrical, physical, and substrate parameter
values are within the range of usage, per user guide.

**Inconsistent Electrical Parameter Value. Ze and Zo must be of the same sign.**

Comment: Ze and Zo must be of the same sign.

Category: Ze and Zo must be of the same sign.

How to resolve it: Use the same sign for both Ze and Zo.
LineCalc AEL Functions

This section describes the supported AEL functions for the LineCalc User Interface.

lcuiuser_analyze()

Computes the electrical parameters from the physical parameter values. In addition, the result parameters are computed. Returns: None.
See also: lcuiuser_synthesize(), lcuiuser_simulation_analyze(), lcuiuser_simulation_synthesize()

Syntax:

defun lcuiuser_analyze()

Example

lcuiuser_analyze();

lcuiuser_elemid_select()

Displays the dataset belonging to the specified component ID, elemID. Returns: None.
See also: lcuiuser_elemtype_select()

Syntax:

defun lcuiuser_elemid_select( elemID )

where

elemID is the component ID to be displayed.

Example

lcuiuser_elemid_select( "MLIN_DEFAULT");
lcuiuser_elemid_select_apply()

Obsolete; see lcuiuser_elemid_select().

lcuiuser_elemtype_select()

Displays the dataset belonging to the specified component type, elemType. If there are multiple components in the memory for a given component type, the first component type found from the list is displayed. To display a component type that has a specified ID, select the component by ID by calling the lcuiuser_elemid_select_apply function. Returns: None.
See also: lcuiuser_elemid_select()

Syntax:
defun lcuiuser_elemtype_select (elemType)

    where
    elemType is the component type to be displayed.

Example

lcuiuser_elemtype_select("MLIN");

lcuiuser_elemtype_select_apply()

Obsolete; see lcuiuser_elemid_select.

lcuiuser_file_chdir_ok()

Performs a change directory command to the specified directory, dirName. If a local configuration file (linecalc.cfg) exists, the function reads in the information and, if needed, overwrites any default values. If the current component has been modified and has not been saved, a question dialog box opens asking if the current component should be saved prior to performing a change directory command. Returns: None.
See also: lcuiuser_file_save(), lcuiuser_file_save_as_ok()

**Syntax:**

```
defun lcuiuser_file_chdir_ok(dirName)
    where
    dirName is the directory to go to
```

**Example**

```python
lcuiuser_file_chdir_ok("dirName1");
```

### `lcuiuser_file_exit()`

Exits the LineCalc User Interface program. If the current component set is not saved, a dialog box opens asking if the data should be saved prior to exiting the program. If no data needs to be saved, a different dialog box opens asking to confirm the exit command. Returns: None.

See also: lcuiuser_file_save(), lcuiuser_file_save_as_ok()

**Syntax:**

```
defun lcuiuser_file_exit()
```

**Example**

```python
lcuiuser_file_exit();
```

### `lcuiuser_file_new()`

Displays the default component. The default component is the first component being displayed when the LineCalc User Interface is invoked. If the component is not saved yet, a dialog box opens so that the component can be saved prior to switching to a different component. Returns: None.

See also: lcuiuser_file_save(), lcuiuser_file_save_as_ok()
**Syntax:**
defun lcuiuser_file_new()  

**Example**
lcuiuser_file_new();

---

**lcuiuser_file_open_ok()**

Opens the data file specified by filename and displays the data properly. If the current component is not saved yet, a dialog box opens so that the data can be saved before moving on to a different component set. Returns: None.
See also: lcuiuser_file_save(), lcuiuser_file_save_as_ok()

**Syntax:**
defun lcuiuser_file_open_ok(filename)

```
    where
    filename is filename to be opened
```

**Example**
lcuiuser_file_open_ok("dirName1/linecalc1.lcs");
or
lcuiuser_file_open_ok("linecalc1.lcs");

---

**lcuiuser_file_print()**

Sends the displayed data to a printer using the program's Hardcopy Server. Returns: None.
See also: lcuiuser_file_print_setup()

**Syntax:**
defun lcuiuser_file_print()

**Example**

lcuiuser_file_print();

**lcuiuser_file_print_setup()**

Opens the print setup dialog box to set the printer selections using the program's *Hardcopy Server*. Returns: None.
See also: lcuiuser_file_print()

**Syntax:**

defun lcuiuser_file_print_setup()

**Example**

lcuiuser_file_print_setup();

**lcuiuser_file_save()**

See also: lcuiuser_file_save_as_ok()

**Syntax:**

defun lcuiuser_file_save()

Saves the data to the current data filename. If there is no associated data file for the current component or if write permission is not set for the current data file, opens the File Selection dialog box to either select or enter the filename to save the data. Returns: None.

**Example**
lcuiuser_file_save();

\textbf{lcuiuser_file_save_as_ok()}

Saves the currently displayed component to a different file, specified by filename. Returns: None. See also: lcuiuser_file_save()

Syntax:

defun lcuiuser_file_save_as_ok(filename)

where

\textit{filename} is filename to be saved

Example

lcuiuser_file_save_as_ok("filename1.lcs");

\textbf{lcuiuser_option_cmdline_apply()}

Executes the AEL command string, \textit{cmdString}. Returns: None. See also: lcuiuser_option_pbmacro_ok()

Syntax:

defun lcuiuser_option_cmdline_apply(cmdString)

where

\textit{cmdString} is AEL command string to be executed

Example

lcuiuser_option_cmdline_apply("lcuiuser_file_exit()");
lcuiuser_option_pbmacro_ok()

Executes the specified AEL macro file, filename, which contains a set of supported AEL functions. Returns: None.
See also: lcuiuser_option_cmdline_apply()

Syntax:

defun lcuiuser_option_pbmacro_ok(filename)

where

filename is AEL macro file to be executed

Example

lcuiuser_option_pbmacro_ok("macro1.ael");

lcuiuser_set_angle_unit()

Sets the angle unit to the specified string, angleUnitString. Note that angleUnitString must be one of the unit strings supported by LineCalc. The supported angle units are: deg, and rad. Returns: None.
See also: lcuiuser_set_freq_unit(), lcuiuser_set_freq_value(), lcuiuser_set_length_unit(), lcuiuser_set_res_unit()

Syntax:

defun lcuiuser_set_angle_unit(angleUnitString)

where

angleUnitString is the new angle unit string

Example

lcuiuser_set_angle_unit("deg");
**lcuiuser_set_elec_res_unit()**

Sets the unit of specified electrical parameter parmName, to the specified string, elecUnit. Note that elecUnit must be one of the unit strings supported by LineCalc. The supported units for electrical resistance parameters are: ohm and kohm. The supported units for electrical angle parameters are: deg, and rad. Returns: None. See also: lcuiuser_set_mwall_length_unit(), lcuiuser_set_phys_length_unit(), lcuiuser_set_subst_length_unit().

**Syntax:**

defun lcuiuser_set_elec_res_unit ( parmName, elecUnit )

    where
    parmName is electrical parameter name of unit to be modified
    elecUnit is new electrical unit string

**Example**

lcuiuser_set_elec_res_unit("E_Eff", "rad");
lcuiuser_set_elec_res_unit("Z0", "kohm");

**lcuiuser_set_electrical_parms()**

Sets the electrical parameter value of parameter name, parmName, to parmValue. parmName must be one of the valid electrical parameter for the currently displayed component. Returns: None. See also: lcuiuser_set_physical_parms(), lcuiuser_set_physical_parms_fix().

**Syntax:**

defun lcuiuser_set_electrical_parms(parmName, parmValue)

    where
    parmName is electrical parameter name to be modified
    parmValue is new electrical parameter value

**Example**

lcuiuser_set_electrical_parms("E_EFF", "360");
**lcuiuser_set_freq_unit()**

Sets the frequency unit string value, freqUnitString. Note that freqUnitString must be one of the unit strings supported by LineCalc. The supported frequency units are: GHz, MHz, kHz, and Hz. Returns: None.

See also: lcuiuser_set_angle_unit(), lcuiuser_set_freq_value(), lcuiuser_set_length_unit(), lcuiuser_set_res_unit()

**Syntax:**

```python
defun lcuiuser_set_freq_unit(freqUnitString)
    where
    freqUnitString is the new frequency unit string
```

**Example**

```python
lcuiuser_set_freq_unit("GHz");
```

**lcuiuser_set_freq_value()**

Sets the frequency unit value, freqUnitValue. It should be passed as a string value.

Returns: None.

See also: lcuiuser_set_angle_unit(), lcuiuser_set_freq_unit(), lcuiuser_set_length_unit(), lcuiuser_set_res_unit()

**Syntax:**

```python
defun lcuiuser_set_freq_value(freqUnitValue)
    where
    freqUnitValue is the new frequency unit value
```

**Example**

```python
lcuiuser_set_freq_value("10.00");
```
**lcuiuser_set_length_unit()**

Sets the length unit string value, lengthUnitString. Note that lengthUnitString must be one of the unit strings supported by LineCalc. The supported length units are: in, mil, m, cm, mm, and um. Returns: None.

See also: lcuiuser_set_angle_unit(), lcuiuser_set_freq_unit(), lcuiuser_set_res_unit()

**Syntax:**

defun lcuiuser_set_length_unit(lengthUnitString)

    where
    lengthUnitString is the new length unit string

**Example**

lcuiuser_set_length_unit("mil");

**lcuiuser_set_mwall_length_unit()**

Sets the unit of specified mwall parameter parmName, to the specified string, mwallUnit. Note that mwallUnit must be one of the unit strings supported by LineCalc. The supported length units for mwall length parameters are: mil, um, mm, cm, meter, in, and ft.

Returns: None.

See also: lcuiuser_set_phys_length_unit (), lcuiuser_set_subst_length_unit(), lcuiuser_set_elec_res_unit ()

**Syntax:**

defun lcuiuser_set_mwall_length_unit ( parmName, mwallUnit )

    where
    parmName is mwall parameter name of unit to be modified
    mwallUnit is new mwall unit string

**Example**

lcuiuser_set_mwall_length_unit ( "Wall1", "mil" );
lcuiuser_set_mwall_length_unit ("Wall2", "um");

**lcuiuser_set_physical_parms()**

Sets the physical parameter value of the specified parameter name, parmName, to parmValue. parmName must be one of the valid physical parameter for the currently displayed component. Returns: None.
See also: lcuiuser_set_electrical_parms(), lcuiuser_set_physical_parms_fix()

**Syntax:**

defun lcuiuser_physical_parms(parmName, parmValue)

where

*parmName* is physical parameter name to be modified

*parmValue* is new physical parameter value

**Example**

lcuiuser_set_physical_parms("W", "25.00");

**lcuiuser_set_physical_parms_all()**

Obsolete.

**lcuiuser_set_physical_parms_fix()**

Sets the physical parameter fixed value of the specified parameter name, parmName, to fixValue. fixValue should be either 0 or 1. parmName must be one of the valid physical parameter for the currently displayed component. Returns: None.
See also: lcuiuser_set_electrical_parms(), lcuiuser_set_physical_parms()

**Syntax:**

defun lcuiuser_set_physical_parms_fix(parmName, fixValue)
where
\( \text{parmName} \) is physical parameter name to be modified
\( \text{fixValue} \) is new fixed physical parameter(either 0 or 1)

**Example**

```c
lcuiuser_set_physical_parms_fix("W", 0);
```

**lcuiuser_set_phys_length_unit()**

Sets the unit of specified physical parameter parmName, to the specified string, physUnit. Note that physUnit must be one of the unit strings supported by LineCalc. The supported length units for physical length parameters are: mil, um, mm, cm, meter, in, and ft. Returns: None.
See also: lcuiuser_set_mwall_length_unit(), lcuiuser_set_subst_length_unit(), lcuiuser_set_elec_res_unit().

**Syntax:**

```c
defun lcuiuser_set_phys_length_unit ( parmName, physUnit )

    where
    \( \text{parmName} \) is physical parameter name of unit to be modified
    \( \text{physUnit} \) is new physical unit string
```

**Example**

```c
lcuiuser_set_phys_length_unit ( "W", "mil" );
```

**lcuiuser_set_res_unit()**

Sets the resistor unit string value, resUnitString. Note that it must be one of the unit strings supported by LineCalc. The supported resistor units are: kohm and ohm. Returns: None.
See also: lcuiuser_set_angle_unit(), lcuiuser_set_freq_unit(), lcuiuser_set_length_unit().

**Syntax:**

```c
defun lcuiuser_set_res_unit ( resUnitString )
```

**Example**

```c
lcuiuser_set_res_unit ( "kohm" );
```
defun lcuiuser_set_res_unit(resUnitString)

    where
    resUnitString is the new resistor unit string

Example

lcuiuser_set_res_unit("ohm");

**lcuiuser_set_shared_parms()**

Obsolete; see lcuiuser_set_subst_parm_value().

**lcuiuser_set_subst_length_unit()**

Sets the unit of specified shared parameter parmName, to the specified string, substUnit. Note that substUnit must be one of the unit strings supported by LineCalc. The supported length units for shared length parameters are: mil, um, mm, cm, meter, in, and ft. Returns: None.

See also: lcuiuser_set_mwall_length_unit (), lcuiuser_set_phys_length_unit(), lcuiuser_set_elec_res_unit ()

Syntax:

defun lcuiuser_set_subst_length_unit ( parmName, substUnit )

    where
    parmName is shared parameter name of unit to be modified
    substUnit is new shared unit string

Example

lcuiuser_set_subst_length_unit ( "Hu", "mil");

**lcuiuser_set_subst_parm_value()**
Sets the shared parameter value of the parameter name, parmName, to parmValue. 
parmName must be one of the valid shared parameter for the currently displayed 
component. Shared parameters are substrate, tand, mcover, mwall, perm, and sigma 
parameters. In addition, shared parameters for COAX and RWG components include those 
listed in References/Shared Parameters”. Returns: None.

**Syntax:**

```python
defun lcuiuser_set_subst_parm_value(parmName, parmValue)
    where
    parmName is shared parameter name to be modified
    parmValue is new shared parameter value
```

**Example**

```
lcuiuser_set_subst_parm_value("ER", "9.91");
```

**lcuiuser_simulation_analyze()**

Computes the electrical parameters from the physical parameter values. In addition to 
computing the electrical parameters, the result parameters are computed. Returns: None. 
See also: lcuiuser_analyze(), lcuiuser_synthesize(), lcuiuser_simulation_synthesize()

**Syntax:**

```python
defun lcuiuser_simulation_analyze()
```

**Example**

```
lcuiuser_simulation_analyze();
```

**lcuiuser_simulation_interrupt()**

Interrupts the simulation. LineCalc remains available for future simulation usage. Returns: 
None.
See also: lcuiuser_simulation_stop()

**Syntax:**
defun lcuiuser_simulation_interrupt()

**Example**
lcuiuser_simulation_interrupt();

**lcuiuser_simulation_stop()**
Interrupts the simulation process and the LineCalc engine becomes unavailable. If a user requests another simulation to be done, the LineCalc engine is invoked automatically. Returns: None.
See also: lcuiuser_simulation_interrupt()

**Syntax:**
defun lcuiuser_simulation_stop()

**Example**
lcuiuser_simulation_stop();

**lcuiuser_simulation_synthesize()**
Computes the physical parameters from the electrical parameter values. In addition to computing the physical parameters, the result parameters are computed. Returns: None.
See also: lcuiuser_analyze(), lcuiuser_synthesize(), lcuiuser_simulation_analyze()

**Syntax:**
defun lcuiuser_simulation_synthesize()
Example

lcuiuser_simulation_synthesize();

**lcuiuser_synthesize()**

Computes the physical parameters from the electrical parameter values. In addition to computing the physical parameters, the result parameters are computed. Returns: None. See also: lcuiuser_analyze(), lcuiuser_simulation_analyze(), lcuiuser_simulation_synthesize()

Syntax:

defun lcuiuser_synthesize()

Example

lcuiuser_synthesize();